Câbler et configurer un moteur "sensored"

Salut,

Voici un petit tuto très rapide sur le câblage et configuration d’un moteurs dit “sensored”.
Les moteurs “sensored” sont des moteurs sur lesquels sont montés 3 capteurs à effet hall placés à 120° l’un de l’autre.
Une sonde de température est également implémenté.

ATTENTION : Dans ce tuto, je vais parler de mon cas, et donc donner les instructions pour un moteur Alien Power System.
Je ne suis pas responsable des mauvais câblages et encore moins des dégradations du matériel dans ce cas. :stuck_out_tongue:

Mais je donnerai aussi la description de chaque fil de façon à s’y retrouver avec un autre moteur (mais à vous de trouver l’info pour le connecteur).

CABLAGE

Sur mon moteur, le connecteur des sensors est un JST-ZH (1,5mm) mâle.
Pour la connexion au VESC, il faut donc :

  • 1 connecteur JST-ZH mâle 6-pin (côté moteur)
  • 1 connecteur JST-PH mâle 6-pin (côté VESC)

Le câblage est le suivant :

Note : Numérotation des Pin des VESC : 1 = proche de l’USB, 6 = proche du microcontrôleur (grosse puce carré noire)

N° pin VESC - Description - Couleur du fil moteur

1 - 5V - Jaune
2 - Capteur température - Vert
3 - Sensor Hall 1 - Bleu
4 - Sensor Hall 2 - Blanc
5 - Sensor Hall 3 - Noir
6 - GND - Rouge

CONFIGURATION

Note : je ne vais parler que de la configuration en mode de contrôle “BLDC” et non en “FOC”.

Une fois câblé, mettre la planche sur le dos (pour mettre la roue motrice en l’air :smiley: ).
Connecter le VESC à l’ordinateur par le câble USB et démarrer BLDC Tool.
Se connecter au VESC et se rendre sur la page Motor Configuration > BLDC

1 - Cliquer sur Read Configuration
2 - Cliquer sur Start Detection. Le moteur se lance et effectue une petite séquence de marche.
3 - Copier les valeurs dans la fenêtre de droite sous la phrase “Detected hall sensor table”.
4 - Reporter ces valeurs dans la table Hall sensors
5 - Activer le mode Hybrid (et non Sensored) en haut de la fenêtre
6 - Cliquer sur Write configuration pour envoyer les paramètres au VESC

Enjoy le Sensored !

N’hésitez pas à partager vos impressions !

Pour faire une comparaison avec/sans, il suffit de switcher entre Sensorless / Sensored (à l’étape 5) sans toucher au valeurs de la table et de faire un Write configuration.
Voir la vidéo ci-dessous :

NOTE : sur la vidéo, vous me voyez activer la fonction Sensored. Il est préférable d’utiliser la fonction Hybrid à la place (désactivation des sensors lorsque la vitesse est élevée et donc que les sensors deviennent inutiles)

[youtube]


[/youtube]

+1 !!
Une fois encore, merciii Pimousse :wink:
ça me donne envie de ressortir mes sensors 0Design … faut que je vois avec quel moteur ils seraient compatible.

en tous cas j’aime voir et entendre un réel changement !! :slight_smile:

@Pimousse

Tu as ressenti un changement ou le changement c’est maintenant ?

A vrai dire, le seul moment de test c’était celui de la vidéo. :smiley:
Tout est démonté, j’ai les boitiers à faire :wink:

A l’origine je suis parti sur un moteur sensored car l’été en longboard je dois souvent poser le pied par terre ou rouler au pas tellement y’a de touristes le long du lac.
Avec le sensored, le départ arrêté et l’allure très faible sont mieux gérés (apparemment), d’où le choix technique .

Merci pour le tuto. !

Envoyé de mon iPhone en utilisant Tapatalk

@toleg, tu peux tenter d’enlever la signature Tapatalk de tes messages?!

Je fais de la pub pour le chat :slight_smile: nan c’est bon j’ai trouvé l’option pour virer La signature :slight_smile:

Bon j’ai un failed. les couleurs de mes cables sensored ne correspondent pas au tiens.
Il n’y a rien de standard dans les couleurs JST / Moteur.
Rajoutes le dans le tuto, c’est à chacun de faire sa correspondance de A à Z. :lol:

Bon j’ai trouvé les miennes, je vais voir si rien n’est cramé.

C’est pas faute de l’avoir dit ! :twisted:

Dans ce tuto, je vais parlé de mon cas, et donc donner les instructions pour un moteur Alien Power System. Mais je donnerai aussi la dénomination de chaque fil de façon à s'y retrouver avec un autre moteur (mais à vous de trouver l'info pour le connecteur).

Mais si c’est pas clair, je modifie. :wink:
Pour ma part, c’est Bruno d’APS qui me les a transmis

Hey gringo,

Table détectée, c’est bon demain je suis sensored :slight_smile:

J’avais fait la correspondance des couleurs de mon JST qui étaient différentes du tien mais je pensais que pour le moteur c’était standard.

Voici le 6374 de TorqueBoards (DIYES) :

Ci dessous : Pin ID VESC >> Couleur JST coté VESC > Couleur JST coté Moteur 6374

1 >> Vert > Red = 5v
2 >> Orange > White = Temp
3 >> Jaune > Blue = A
4 >> Blanc > Yellow = C
5 >> Rouge > Green = B
6 >> Noir > Black = GND

C’est bon ça !!!

Les couleurs du JST changent d’un JST à l’autre (sur les paquets que je commande, les couleurs changent souvent).
Quand tu dis “Couleur JST coté Moteur 6374”, ce sont les couleurs de fils du moteur (des capteurs jusqu’au JST-ZH) ?

J’ai hâte de lire tes impressions ! Surtout à très bas régime et départ arrêté. :wink:

C’est bon ça !!!

Les couleurs du JST changent d’un JST à l’autre (sur les paquets que je commande, les couleurs changent souvent).
Quand tu dis “Couleur JST coté Moteur 6374”, ce sont les couleurs de fils du moteur (des capteurs jusqu’au JST-ZH) ?

J’ai hâte de lire tes impressions ! Surtout à très bas régime et départ arrêté. :wink:

Ne comptes pas sur moi:
Je viens certes me mettre en sensored mais je viens également de corriger le bug du Max current ramp step (j’étais à 50.000). Je ne saurais donc pas d’ou viens l’amélioration…

Fais un ride sensorless puis sensored (Tu as juste à switcher de mode sans toucher à la table) si tu peux . :wink:
Pour le bug de la ramp, télécharge la dernière version de BLDC Tool :
http://vesc.net.au/BLDC-TOOL/

J’ai fait le test et répondu depuis tapatalk mais je ne le vois pas (en espérant ne pas avoir posté ailleurs) :lol:

T’as posté dans le tuto bluetooth :wink:

la loose :expressionless:

Salut Pimousse,
Je.ai appris pour tes mésaventures avec la blue lake ca me laisse craintif avec mon build…
Dis moi le connecteur Jst ZH côté moteur c’est du 1.5 ou 2.0 ?

JST ZH = 1.5
2.0 c’est du JST PH

Faut prendre soin de bien brancher/débrancher le moteur avec les bonnes phases au bon endroit sinon la table Hall entrée dans le VESC est plus bonne et donc le moteur se lance pas (il essaye mais n’arrive pas).
Et utiliser le mode Hybrid et pas Sensored.

Ok merci pour les infos Pimousse, c’est donc pour cela que je ne trouvais pas de 2.0. :lol: on en apprend chaques jours.

Un tableau très intéressant (qui me sert souvent d’ailleurs ):
https://en.wikipedia.org/wiki/JST_connector