[Build log] e-BMX

Salut, ça fessait un temps que j’avais envie de m’essayer à foutre un moteur sur un BMX, une belle occasion leboncoin a fini par me décider, seul le pédalier est H.S rien de grave et le prix et excellant. Je considère le projet plus comme un « passetemps » plus pour apprendre que pour le produit final. En termes de philosophie de build je suis partisan du fait que faire simple (mais pas simpliste) c’est gage de fiabilité.

**Ce sera un « mid drive » aka moteur central/propulsion donc me faut donc un moteur capable dans le triangle arrière et une transmi’ sur l’arrière : **

  • le 8084 100kv flipsky me semble pas mal mais on y reviendra. (80100 dans le lien car le 84 n’est plus vendu sur site)

  • J’opte pour un moyeu de vélo à double fixation de « freewheel », une pour conserver la freewheel d’origine le second pour un plateau a pignon de pocket bike monté sur freewheel, le tout sera souder en place.

C’est un 80 dents, pignon de pocket bike oblige, tout est en chaine « 25H »

  • le tout sera sur un vesc 6 trampa que j’avais en stock et les pack lipo de 12s en sacoche qui tournent déjà sur tous mes builds de skate et sur mon drift trike.

Et la commence le build

J’avais fait attention à prendre du 36 trous partout donc je mets rayons et jante d’orig’ sur le nouveau moyeu. Je soude le tout (freewheel sur elle-même et sur le moyeu) à l’arc autrement le sens de la marche dévisse la freewheel. Je me rends rapidement compte que la chaine va toucher le triangle arrière donc je déporte à coup d’écrous défiltées et de rondelles (oui le pignon est prisonnier) ce n’est pas nul.

Viens le support moteur

@tignous que je remercie me fournit un gros plat de 3mm d’épaisseur. Je la mets en forme avec les bons perçages, les bons déports et une bonne longueur en prévision de la soudure sur le cadre.

Comme je m’apprête à souder sur le cadre autant se faire plaisir et virer toute la peinture avant de souder la plaque en profiter pour lui faire une nouvelle.

Je présente la mount et l’aligne du mieux que je peux en prolongeant l’orientation de la couronne avec un long plat. Alors que la Mount tiens au serre-joint sur le cadre je m’assure d’avoir la même distance en tout point entre le long plat et ma plaque.

Une fois fait, je la pointe, soude, mastic

Je ne suis pas extra en soudure à la baguette d’autant plus que souder du 3mm sur la tôle toute fine du châssis sans faire de trous ce n’est vraiment pas évident. Le « secret » était de faire la méthode « raclette », donc bien faire fondre la plaque jusqu’à faire « couler » le métal sur le châssis avant de fusionner le tout avec un très rapide coup d’arc coté châssis. Je n’étais pas très rapide mais les soudures sont bonnes et je n’ai fait qu’un trou. Meule pour la rendre plus agréable a l’œil et mastic pour les tout petit trous puis ça passe en peinture.

Épargne + dégraissage acétone

Apprêt

Couleur

Puis après c’est du rapide

Je présente le moteur et la chaine, la tension se fait au recul de la roue avec des petit tendeurs à visser sur l’encoche de la fourche.

Et c’est chaud ya le même gap coté roue

Un premier petit problème

Un plus petit plateau ne sera pas de trop

Impression 3d

VESC

Et batterie, elle sera vissée sur des « riveklés » aka des rivets avec filetage écraser dans le châssis encore une fois merci a @tignous pour son matos.

Avec un petit lissage de l’ABS, on n’est pas des sauvages

Comme d’hab’ vesc tool, quelques soudure, montage a l’arrache et :

On ne le voit pas mais la manivelle touche le cul du moteur donc j’ai décalé tout le pédalier avec un calle imprimer en 3d. Ready pour un test, je suis uniquement en freinage régen’ le guidon n’est pas droit, les trucs tiennent au zip tie, je n’ai pas encore de pédales (de toute façon la chaine ne passe pas avec ce plateau) bref, tout est parfait !

Les problèmes

Hé bah… c’est de la merde et je m’en doutais un peu, je m’explique… Sur de fortes accélérations le moteur « craque » un peu comme une chaine de vélo qui passe une vitesse mais en vraiment plus fort. En termes de sensation c’est vraiment similaire à ce que j’ai pu voir dans cette vidéo (à ce time code) : https://youtu.be/1pm1RtCuE3A?t=373

Et je pense que j’ai le même problème avec mon tube de selle que passe trop proche des magnets. La loi de Lenz’ doit faire sont effet les courant induits forcent contre le moteur.

Au final le moteur était bouillant sur les premiers tests, j’ai baissé l’ampérage pensant que c’était le problème mais lors du second test, il a totalement brulé.

J’ai commandé un maytech 8084, c’est le seul qui a encore assez de pèche de par son format et présente un KV acceptable. En réalité il fait 74 de long donc plus court que le 8084, je compte là-dessus pour le décaler de la mount avec de l’impression 3d sans qu’il touche la manivelle et sortir au maximum les magnets de la proximité du tube de selle. Si ça ne fonctionne pas alors je mettrais le vesc sur la mount et je souderai une autre mount pour le moteur juste derrière la selle à l’emplacement actuel du vesc.

Voilà, affaire à suivre. (ou pas :slight_smile:)

11 « J'aime »

Moteur qui chauffe… kv trop haut ? :thinking: tubas besoin de combien de tr/min pour rouler à 45kmh?

Ah le retour de tes builds improbables de dingo j’adore!
tu as combien de dents sur ton pignon moteur?
Parce qu’au final 80 dents sur ta couronne côté roue, c’est le meme ordre de grandeur que sur les mtb en courroie avec 66/72 dents.
vu que ta roue doit etre une 20 pouces, ca te fait plus de 2 fois plus qu’un mountainboard. il te faut un tout petit pignon 12 dents sur le moteur (voire une double réduction?)
http://calc.esk8.it/#{« batt-type-lipo »:1,« batt-cells »:12,« motor-kv »:100,« system-efficiency »:85,« motor-pulley-teeth »:11,« wheel-pulley-teeth »:80,« wheel-size »:450}|

1 « J'aime »

en faite, 80kv le 8084, je l’ai mis en 12 dents

Je pense que c’est la loi de lenz qui m’a mis dedans

je calcule … 45kmh à la roue de 20" , ça fait 470tr/min.
avec ta démultiplication 80/12, ça fait 3100 au moteur . un 80Kv en 12s tourne au max à 3050tr/min . donc c’est cohérent … je comprends pas qu’il chauffe … .

Ah bah oui sur le papier tout etait bien. La pour le coup il ya une résistance constante et exponentiel a la vitesse de rotation (a la main) donc au moins deux des trois phases sont soudée ensembles. Petite magic smoke et tout, le compte est bon. Et je sais pas quoi en faire :no_mouth:

en faisant un log sur vesctool … tu vois rien ? il tourne bien à vide ? dans et hors chassis ? pour vérifier ta tehorie de l’effet de lenz . il ne serait pas un peu en CC dans les bobinages ?

j’ai pas remis le couvert je suis même pas sur que le vesc 6 sois encore vivant, si ce n’est pas le cas je passe sur le 75100 flipsky que j’ai en stock. Ce que je peut dire c’est qu’avant qu’il se suicide tout etait parfait sous vesc tool, detection sensors prise de vitesse rpm max, TOUT etait parfait. La déconnade c’etait uniquement en charge, donc avec de l’ampérage, d’ou la théorie du lenz’


8085 flipsky | 8085 maytech (50kv) | 63100


Des phases au diamètre merdique


J’ai mon moteur, entre temps j’ai mis un pignon plus petit niveau pédalier, la chaine ne tape plus dans le moteur mais viens « lécher » la cloche. Il me faut donc descendre le moteur mais c’est pas forcement une mauvaise nouvelle car de toute façon les perçages de fixation sur la plaque ne sont pas les mêmes.

Pour en revenir a mon problème de courant induit, le moteur est bien moins long que l’ancien (alors que c’est théoriquement le même format), c’était le but et ca me donne une possibilité de déport d’environ 2cm avec une calle d’ABS sans qu’il touche la manivelle, j’espère que ca sort complètement les magnets de l’action du tube de selle ( en tout cas ils sont vraiment plus du tout en face)

2 « J'aime »






J’ai tout remis en place avec au passage un 75100 et le moteur déporter par impression 3d.
Comme vous pouvez le voir la cloche sors totalement du tube de selle. Nouveau pignon juste collé

Bah c’est de la merde, j’ai toujours le même problème avec les mêmes symptômes.
Nouveau moteur nouveau vesc… du coup penche toujours pour l’option de ces courants induits de ces morts.
Je me suis donc mis a bosser pour réaliser ce que j’avais dit plus haut, mettre le moteur derrière la selle et le vesc a l’emplacement actuel du moteur.





La base est prête reste a souder un gros plat qui me déporte le moteur plus en hauteur et au dessus de la roue arrière. Encore une fois je ne suis pas soudeur, souder sur le tube hyper fin du cadre c’était vraiment pas facile, j’ai fait plein de trous partout mais après un voile de mastique ce sera propre et solide.

3 « J'aime »

Et si tu mettais une cage métallique sur le rotor en alu? Ça rebouclerais le champ magnétique des aimants uniformément ? Et non pas dans un tube du cadre au hasard…:thinking::skateboard::no_mouth:

Sur le papier c’est une bonne solution physique, dans les fait l’investissement technique est trop gros. J’ai pas de quoi souder l’alu, j’ai pas de quoi le fixer au cade, j’ai pas la place (le pneu lèche le stator) donc c’est non.

Une simple bague en fer magnétique suffirait.meme fine.pas la.peine de souder si elle est bien ajustée sur le.rotor en alu.

je vais plutôt continuer mon idée, normalement une fois perché la haut ya plus rien pour faire chi*** et si ca le fait toujours, alors la j’ai plus d’idées.

Dailleurs,cette cage magnétique nest pas obligée de tourner avec le rotor . Elle peut-être fixée au cadre . Le but c’est d’avoir un champ magnétique arrière uniforme sur tous les aimants…



Je suis aller me choper 3 kilos de rail de chemin de fer que j’ai trouver chez un ferrailleur, ca m’a couter trois euros et quatre disque a tronçonner pour l’extraire et le mettre en forme. C’est du dix millimètre de large alors ce sera trés trés (trop ?) rigide

En parallèle, les batteries de la disqueuse n’assument pas de couper aussi gros





donc j’ai 3d printé un adapteur ryobi male rempli de colle chaude et couler une tige fileté avec écrou dedans pour me faire une prise quand je l’enfonce et le retire. C’est pas le plus glorieux mais je m’en branle ca iras trés bien. bricoler et souder deux contact en fer plat + 16 AWG et hop, direct sur la batterie lipo 5s 16Ah (et j’en ai deux) j’ai maintenant de quoi meuler et disquer a pleine balle pendant 1h30-2h contre 20 minutes avant ca, c’est pas trés beau mais ca m’a pris 20 minutes et le travail est fait.

7 « J'aime »










J’ai commencer par pointer un angle de ma pièce sur le châssis puis, toujours par prolongement de la couronne au fer plat, j’ai fait en sorte de mesurer quasiment le même écartement en tout point. Je rectifie l’alignement avec des petits coups de marteau. Pour le coup j’ai 0.2mm de différence ce que j’estime correct alors j’ai souder définitivement.

Les cordons sont solide, mastique, ponçage a niveau, apprêt, noir mat. Un magnifique chibron que voila.

Il est volontairement bien trop long pour j’espère pas être emmerdé, si le test a venir fonctionne, pourquoi pas le couper de moitié

1 « J'aime »

et la… j’ai plus d’idées.
Sa « craque » plus sur un full throttle mais ca chauffe toujours autant.
Baisser le duty cycle ?

2 « J'aime »

qui chauffe ? l’esc ? essaies de diminuer le « switching frequency » .

l’esc peut être mais surtout, le moteur.