Repérage phases moteur brushless sensored ? comment?

Bonjour à tous,
je viens de tomber sur un article de chez Overion sur les phase moteur ( https://www.overion.fr/2017/01/23/reperage-des-phases-dun-moteur-brushless-sensored/ ).

Je possède un vesc 4.10 avec moteur Turnigy sensored 14P 125kv. Sur ce moteur les phases ne sont pas repérées, je pense donc qu’il faut que je les trouve moi même pour optimiser le rendement du moteur ?
merci pour vos conseils !

Sur ma Unity, le repérage se fait tout seul, c’est le contrôleur qui trouve pendant la configuration.
Si tu dois quand même faire le repérage, pour repérer les phases quand j’ai reçu mes nouveaux moteurs,
J’avais fait une checklist en récapitulant les infos reçue par Yann.

Repérage phases moteur sensored.
6 possibilités: 3 câbles moteur et 3 sorties contrôleur.
1/ A -> 1 B-> 2 C-> 3
2/ A-< 2 B-> 3 C->1
3/ A->3 B->1 C-> 2
4/ A->1 B->3 C->2
5/ A->2 B->1 C->3
6/ A->3 B->2 C->1

  • Utiliser la gâchette très très légèrement.
  • Scotch ou gaine thermo pour repérage.
  • Brancher sensor
  • Petite soudure des câbles (6 possibilités on trouve souvent + vite)
  • Allumer tout et accélérer très très très légèrement.
    3 possibilités de réaction du moteur:
    1 --> click: c’est pas bon
    2 --> grrrr: c’est pas bon
    3 --> ca tourne: c’est bon OU pas
    - si j’accélère de + en +, il s’arrête: c’est pas bon
    - si j’accélère de + en +, il tourne : c’est bon
    ===> repérer avec A, B, C: c’est fini.
    Astuce: Sortie des câbles du moteur, repérer le câble sensor.
    le plus proche est normalement le A
    puis le B et en dernier, le C.
    Attention, c’est juste une information et ce n’est pas toujours le cas, toujours faire le test de rotation quand même.

Merci pour ta réponse.
je vais essayer d’être plus précis sur ma démarche.
Je recherche le branchement des phases qui me donne la meilleure efficacité.
_ Est-ce qu’il y a une réelle différence de rendement selon le branchement des phases ? et si oui, comment la tester.
Si je fais la détection du sensor dans l’application PC du Vesc, le moteur va parfaitement bien tourner quelque soit l’ordre de branchement des phases.

La méthode que je pense tester mais sans être certain d’identifier une réelle différence de rendement:
_ 1er branchement des phases, détection sensor pour que le vesc utilise le moteur en sensored, et ensuite mettre par exemple 20% de gaz et regarder avec un Wattmètre quelle est la consommation.

_ Répéter cette procédure pour les 6 branchements de phases possibles.
_ Enfin, identifier la consommation la plus faible… si une différence est vraiment visible sur le wattmètre.

Vais tenter de tester de cette manière. Si qq’un a une autre idée ?.

Je ne veux pas dire de connerie mais sur un VESC, je pense que le répérage est inutile, c’est tout l’intérêt de la phase de détection, la première fois que tu branches le moteur.
Ensuite, je ne crois pas trop à la différence de rendement évoquée dans l’article… Globalement, le moteur est « symétrique » donc la différence sera peanuts. Le mode de comparaison me fait un peu marré quand même… tu appuies sur la gachette au 1/3, tu te cales sur une vitesse de rotation et tu notes le courant consommé dans les différentes configurations qui marchent : c’est pas très « scientifique » comme approche :grin:

En synthèse, avec un VESC (et je ne parle pas des autres ESC là), une fois que tu as branché les phases dans n’importe quel ordre et que tu as fait la détection du moteur dans VESC Tools, ça marchera, pas besoin de te prendre la tête plus que ça :slight_smile:

1 J'aime

Merci pour les réponses…
Quelques tests rapides et effectivement, pas de différence notable sur la consommation. Pour un réglage précis des gaz, j’ai utilisé la radio Taranis programmable.
Donc en gros, le repérage des phases dans VescTool optimise la config quelque-soit le branchement des phases.
Me reste à régler un problème de température des moteurs. A 35° en journée j’ai les moteurs qui montent à 85 ° assez facilement. ( Mais une protection imprimée 3D en TPU limite sans doute la dissipation thermique de la cage métal du moteur !)
Dans VescTool de Ackmaniac, le log n’enregistre pas la température des moteurs.
J’ai testé le firmware officiel des Vesc pour mon hardware 4.10, mais mon module bluetooth ne fonctionnait plus !
Bref, j’ai l’impression d’avancer d’un pas et de reculer d’autant ensuite…

A noter que dans l’article d’il y a 3 ans, il parlent d’ESC et poussent dans les test d’optimisation vu la techno.
Pour un VESC dans ton cas, une détection moteur et c’est fini.

Fait une aération pour tes protections moteur (passage d’air/ailettes, etc …), ils t’en seront reconnaissants :slight_smile: