Problème "Bad detection results" sur un des moteur

Salut a tous,

esk8builder.com m’a amené ici !

l’année dernière je me suis lancé dans un petit build que je n’ai eu le temps de terminer que maintenant.
Ayant fait des études dans la tech, je pensais que la partie programmation des VESCs se ferait les doigts dans le nez.
Quelle erreur !

Bref pour faire court voila mon setup:

  • 2 moteurs 6355 de chez torqueboards
  • 2 VESCs 4.12 de chez TQ aussi.
  • Connectés par Can Bus (pas pour le setup des moteurs)

J’ai réussi a programmer l’un des moteur, qui tourne désormais avec la télécommande.
Problème: impossible de faire la meme chose pour l’autre.
Petite précision, les moteurs sont “sensored”.

J’utilise VESC tool et voila mes settings.

  • Battery cutoff start : 34 V (3.1 V/cell * 10 cells)
  • Battery cutoff end : 31 V (2.8 V/cell * 10 cells)
  • Motor Type : BLDC
  • Motor Max : 80 A
  • Motor Min : -35 A
  • Batt max : 40 A
  • Batt min : -25 A
  • Absolute max : 130 A
  • Max ERPM : 60000

Si quelqu’un voit quelque chose d’aberrant ou a une idée qui pourrait résoudre mon probleme, je suis preneur, j’ai vraiment envie de rider pour aller au taff, jpp du métro.
Et sinon si quelqu’un est sur Paris et peut m’arranger ça contre rémunération ça peut se faire.

Edit: Ah et aussi quand j’essaie d’utiliser le setup wizard du VESC tool ça a l’air de fonctionner mais les moteurs (en FOC du coup) ne tournent pas une fois la procédure terminée malgré les VESC qui captent le signal (led blanche)…

Merci !

Te voilà !
Alors si t’es sous la dernière version de vesc tool c’est chiadé pour les deux vesc j’ai moi même galéré hier en aidant qqun qui avait le même pb que toi. La solution trouvée est de passer sous esc tool ackmaniac qui marche au top et fait tout bien fonctionner correctement si tu respecte bien le process.
Je suis sur Paris, c’est cool ca fait un de plus dans le coin :wink:

Ton batt min est vraiment énorme, divise le par 2 ou 3 même, t’as quoi comme batterie ?
*Edit je viens de voir, un 10s4 en 30Q, donc oui diminue bien ton batt min sous peine de niquer ton pack

Si seulement j’avais un PC… J’ai trouvé cette version https://github.com/aurimasniekis/vesc_tool_ackmaniac/releases mais c’est la 3.102 alors que le lien de ackmaniac renvoie vers une version 3.103…