VESC HK

Salut à tous,

Je viens de recevoir mon vesc HK, et installé la dernière version de Vesc Tools (v1.13), je n’arrive pas à mettre à jour le firmware et reste en connection “limité” sur le logiciel.
Version fw du vesc : 2.18
Version hardware : 4.12

J’ essaye de mettre la version fw 3.57 et également essayé le bootloader (4.10 & 4.11 & 4.12).
Le problème est il du à une différence trop importante entre les 2 firmwares?
Debug avec un st-link?

Merci d’avance.

Nope, tu vas dans firmware, tu clique sur 410/411/412 puis sur VESC default.bin, puis sur la flèche du bas du FW Upload Status et tu fait ok si t’as bien fait et ca va s’update tt seul, après tu déconnecte et tu reconnecte! Mais va voir le tuto de @Pimousse sur youtube tu auras tout

Je l’ai fait plusieurs fois, ça transfert bien. Cela met un message d’attendre 10s, cela se deconnecte tout seul.
Je débranche la batterie, je me reconnecte et ça dit que le firmware est toujours trop vieux.

Regarde les tutoriels

Tu as flashé le bootloader ?
Si non, essaie ça
Si oui, le bootloader est corrompu : ST-Link nécessaire

Oui j ai essayé de flasher le bootloader.
J attends le st-link.
Merci Pimousse.

Je confirme problème résolu avec le St-link. Merci Manu39 pour le tuto.

3 J'aimes

Heureux que le tuto ai pu te rendre la vie un petit peu plus simple :wink:

1 J'aime